Just purchased Xeroom

Viewing 9 reply threads
  • Author
    Posts
    • #1309
      sean
      Participant

      Hi,
      I just purchased Xeroom and entered my Credit card details.
      I was then was sent to “http://www.xeroom.com/wc-api/WC_Gateway_Stripe/”
      which only shows a blank page with “-1” at the top of page.

      I received login details for your site and when logged in it says under orders,
      my order is listed but says “Pending Payment”.

      I don’t want to be double charged for this product, so I was wondering if this is normal and payment is pending on your end ?
      or Did payment gateway fail / goto an error page & Do I have to re-enter payment details again?

    • #1311
      Peter Lloyd
      Keymaster

      Hi Sean

      Thank you for your note. I am sorry for the payment not going through. I have checked and it not been charged so it looks like the payment failed for some reason. We have been getting Stripe payments with no issue so please can you try again and if it fails again let me know and I will investigate. Could you please send me a screenshot of the page and message so I can pass it on to Stripe support?

      Thanks
      Pete

    • #1312
      sean
      Participant

      Thanks Peter.
      Just before I go ahead, will this definitely integrate with the Australian version of Xero?

    • #1313
      Peter Lloyd
      Keymaster

      Yes of course we have quite a few Australian customers.

    • #1319
      sean
      Participant

      Hi Peter,
      I have purchased my license and whilst setting up in wordpress I got the needs ion cube error, ioncube loader is installed, so I assume its an older version of ioncube loader.

      so I followed links provided & downloaded “xeroom1.5.2.zip” for older ioncube version,
      from your tutorial link.
      I installed & activated licence and all appeared to be working,
      Except whilst activated the WooPos stopped working all together and all online customers could not checkout?

      So I have deactivated Xeroom, and all is working again.

      Server is using PHP 7 and ioncube
      (not sure which version -but will be asking web host to upgrade to 10.2 if possible.)

      I have a few questions.
      1.) Is it normal for POS Checkout & Online Checkout to stop working when xeroom plugin is installed but not synced to xero yet?.

      2.) Also, where do I find / download the provided Keys so I can setup xeroom application in xero?
      (or is it the files in the folder “library/certs”) ?

    • #1321
      sean
      Participant

      Hi Peter,
      Thanks for your reply by email,
      I have upgraded to ioncube loader 10.2 and successfully installed and activated to Xeroom Version 2.0.3,

      However!
      once activated it immediately prevents shoppers on site proceeding to payment gateway.
      and also POS systems can’t complete order transactions either.

      I am using ioncube 10.2 & PHP 7,

      Xeroom Plugin Install worked perfectly & so did activation.
      I input my License Key and activated it correctly also.

      Not sure why it is affecting checkout & pos but I have had to disable plugin again.

      Specifically when Xeroom activate, ONLINE Orders: when customer in checkout and presses place order it does not go to payment gateway it just refreshes checkout page.

      And in Pos when you try to place order it does the same thing?

      How can I figure out why its doing this?

      I will uninstall plugin & manually delete its folder again and try again?
      But i don’t think this will make a difference.

      Any suggestions?

    • #1322
      sean
      Participant

      I uninstalled xeroom plugin & manually deleted the xeroom folder.
      I Re-installed xeroom & activated.

      When activated it still prevents transactions from completing and gets stuck in checkout.
      And same within pos.

      WooPos payment options are Paypal, Cash & afterpay.
      And Online orders can click pay with paypal or pay with afterpay.

      However when xeroom is activated all orders fail / cannot complete any further when “place order” is pressed.
      More specifically it refreshes the checkout or pos screen to same page showing place order button again without proceeding to payment gateway.

    • #1324
      Peter Lloyd
      Keymaster

      Hi Sean

      Ok I am back from my trip now, so sorry for the delay. Can you please tell me what exact version of php you are running as there was a significant change from 7.0 to 7.1 with ioncube loader. Also take a screenshot of your Xeroom settings for me and post it here. Does your SKU exist in Xero that you are purchasing in the checkout?

      Thanks
      Pete

    • #1327
      sean
      Participant

      Hi Peter,
      No Problems,
      hope you had a nice trip, sorry to bug you when you were away. 😀

      Version 7 of php.
      No the SKU exist in Xero, which also prevented me saving any settings in plugin.
      I Also suspect not setting up xero app first in xero was part of the problem.

      Anyway,
      I was set to have meeting with client & setup the xero side of things for them.
      but my client has decided that xero is to hard to use & has opted to use a different bookeeping software…
      🙁

      so now I’m out of pocket for the cost of this plugin.

      I think your product is the best available for xero and your plugin is the only one on the market that does not charge a ridiculous monthly charge.
      But unfortunately I have no use for this plugin now that client doesn’t want to use xero.

      I was wondering is there any chance for me to get a refund? I know its entirely my error, but if you could please consider a refund, it would be greatly appreciated.

      Thank You for all your help over the last few weeks either-way.

      Kind Regards.
      Sean

    • #1328
      Peter Lloyd
      Keymaster

      Hi Sean

      I am sorry to hear that your client is dropping Xero. I wouldn’t want a Xeroom partner to be hit by something like this so am happy to arrange a refund for you.

      Thanks
      Pete

Viewing 9 reply threads
  • The forum ‘Xeroom Support Forum’ is closed to new topics and replies.