Cannot redeclare class oauthconsumer

Viewing 17 reply threads
  • Author
    Posts
    • #7700
      info6
      Participant

      Hi,

      We’ve installed and activated this plugin, tried to go to the settings page in the admin area and nothing shows.
      The php error log shows:

      [01-Feb-2019 11:14:29 UTC] PHP Fatal error: Cannot redeclare class oauthconsumer in <REMOVED>/wp-content/plugins/xeroom/library/xeroom_indexManager.php on line 0

      Can you help?

    • #7702
      Peter Lloyd
      Keymaster

      Hi

      I can certainly try. Please can you check and tell me what versions of xeroom, php, ioncube loader, wordpress and woocommerce you are using? Also a screenshot of the settings page would be useful.

      Thanks
      Pete

    • #7706
      info6
      Participant

      Hi,

      We’re using the following:

      WordPress 5.0.3
      WooCommerce 3.5.3
      Xeroom 2.0.4
      PHP 7.2.14
      ioncube v10.2.4 (from what I can tell)

      I have a screenshot although it can’t be uploaded here?
      It’s basically a completely blank page (with the admin menu and top bar on it).

      Thanks.

    • #7707
      Peter Lloyd
      Keymaster

      Ok thanks those look good but you need to use the latest version of xeroom which is 2.0.5.

    • #7708
      info6
      Participant

      2.0.5 is a beta version according to your downloads page. It’s not recommended to use betas on live/production systems/websites.

      2.0.4 should work, shouldn’t it?

    • #7709
      Peter Lloyd
      Keymaster

      There has been major upgrades in both WordPress and Woo since 2.0.4 was released which could easily affect things. The 2.0.5 non-beta is on the download page.

    • #7710
      info6
      Participant

      I see the 2.0.5 version and have just downloaded and installed it.
      When I activate it I get this same error now.

    • #7711
      Peter Lloyd
      Keymaster

      So could you send me a login to your site please to take a look?

    • #7765
      info6
      Participant

      Hi,

      My reply earlier seems to have been lost here and I couldn’t get logged back in for a while.

      I had to speak to the customer to get approval due to GDPR/Data Protection. I don’t see a policy anywhere on your website.

      I can give you a user/password. How would you like me to send it over?

    • #7770
      info6
      Participant

      Hi,

      Did you see my reply a few days ago? We’d like to get this resolved ASAP as the customer is waiting to use the system.

      Thanks.

    • #7773
      Peter Lloyd
      Keymaster

      Hi – please send me a pm to [email protected] with the details so I can take a look.

    • #7774
      info6
      Participant

      Hi,

      I’ve created an account for you.
      Hopefully, you should get an email from their website with the user/password.

      Any problems please let me know.

    • #7959
      Peter Lloyd
      Keymaster

      This was a conflict with another plugin and has now been fixed with a new class validation for oauth. It is in version 2.0.8 which will be released at the end of this week.

    • #8286
      info6
      Participant

      Hi Peter,

      Just checking on this. Has version 2.0.8 been released yet as I can’t see it on the downloads area?

      Thanks.

    • #8287
      Peter Lloyd
      Keymaster

      Hi – yes sorry the fix has been done by my developer but I need to do the build which I will do tomorrow 🙂

    • #8327
      info6
      Participant

      Hi Peter,

      Sorry to keep pushing on this but our customer is starting to ask serious questions and whether we (and woocommerce) can deliver what he needs.

      I don’t see 2.0.8 on the downloads page yet.

      Thanks.

    • #8394
      info6
      Participant

      Hi Peter,

      Can you tell us what the status is with version 2.0.8?
      It’s been over a month since any update on this and our customer is not very happy, even asking about a refund as compensation. They still need to get this working and it’s putting a bad name on WordPress and Woocommerce in his eyes.

      Please, can you let us know when we should expect version 2.0.8 to fix this issue?

      Thanks.

    • #8407
      Peter Lloyd
      Keymaster

      Hi – I am sorry that this got overlooked and delayed, we had someone in the team suffer a bad bike accident – my developer has now put it in the download area and I have tested it to double check that it is there and downloads fine and also loads and activates correctly.

      Please let me know by if you encounter any further problems.

      Thanks
      Pete

Viewing 17 reply threads
  • You must be logged in to reply to this topic.